The incident affecting our US environment is resolved. Between approximately 18:15 and 20:54 UTC on September 23, 2026, some customers experienced elevated API latency and intermittent request failures. Client creation, case creation, transaction processing, and screening workflows may have been affected. Normal service has been restored.
Posted Sep 23, 2026 - 20:54 UTC
Identified
We have identified the issue causing elevated API latency and intermittent request failures in our US environment. Client creation, case creation, transaction processing, and screening workflows may be affected. We are working to restore normal performance and will provide another update as we verify recovery.
Posted Sep 23, 2026 - 20:46 UTC
Investigating
On September 23, 2026, some customers in our US environment experienced slow API responses and intermittent timeouts, including during client creation and screening workflows. We are investigating the full impact and will provide an update when the incident timeline and resolution are confirmed.