Scheduled maintenance for the Corsa U.S. environment has been completed. Services are operating normally.
Posted Sep 18, 2026 - 11:10 UTC
Update
The Corsa U.S. environment will be temporarily unavailable while we perform scheduled maintenance. Other environments are not affected. We expect service to be restored within 15 minutes.
Posted Sep 18, 2026 - 10:18 UTC
Scheduled
Corsa services will be temporarily unavailable while we perform scheduled maintenance. We expect service to be restored within 15 minutes.
Posted Sep 18, 2026 - 10:15 UTC
This scheduled maintenance affected: Web Application (CRM, Transaction Warehouse, Alerts & Case management) and API (API functionality).